This content is for advanced users and consists of personal notes.

  1. Make sure all the interfaces and/or bridges that need IP addresses, have them.
  2. Make the loopback interface. This is just a bridge that is not connected to anything.
    • /interface bridge
    • add name=OSPF-01
  3. Give the loopback interface an IP address that is unique.
    • Using the loopback with a unique IP won’t let the router go down if a physical interface fails.
    • /ip address
    • add address=172.16.128.1 interface=OSPF-01 network=172.16.128.1
  4. Configure the Router ID
    • /routing/id
    • add disabled=no id=172.16.128.1 name=OSPF-01 select-dynamic-id=
  5. Create the OSPF instance.
    • /routing ospf instance
    • add name=OSPF-01 originate-default=always router-id=OSPF-01
  6. Create the OSPF area
    • /routing ospf area
    • add instance=OSPF-01 name=Backbone
  7. Build a template for each interface that you want to be included. Can be bridges and/or interfaces.
    • /routing ospf interface-template
    • add area=Backbone interfaces=ospfbr01 networks=172.16.128.1/32 type=passive
    • add area=Backbone interfaces=ether3 networks=192.168.1.0/24 type=ptp
    • add area= interfaces=a-bridge networks=10.0.20.0/24 type=ptp

You should do this on both routers (simple example) with the correct IPs for your situation

Thats it it should be working. You can check by looking at the routes: /ip routes print

OR

/routing ospf neighbor print

Aliens? Any thoughts?

This site uses Akismet to reduce spam. Learn how your comment data is processed.